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Chapter 1 Introduction 
CodeNet® allows hospital personnel to efficiently and accurately manage resuscitation information. It 
includes two software programs, CodeNet Writer and CodeNet Central. 

CodeNet Writer is a Windows Mobile program that allows you to: 
• Log real-time code events. 
• Collect medical personnel’s signatures. 
• Upload resuscitation records directly from ZOLL Medical Corporation defibrillators. 
• Attach those records to code events in CodeNet Writer. 

You can then upload the code event and resuscitation information stored in CodeNet Writer to a 
workstation running CodeNet Central, a Windows program that allows you to: 

• Collect resuscitation data. 
• Add information and annotations to an event. 
• View the ECG in its entirety, or in magnified, playback, or analysis mode. 
• Route cases for code audits. 
• Generate case and aggregate reports. 
• Synchronize defibrillator event times and other interventions documented in CodeNet Writer 

to the workstation to provide consistent and accurate times. 
• Submit resuscitation data to the National Registry of Cardiopulmonary Resuscitation 
• (NRCPR), using the NRCPR interface in CodeNet Central. 

The NRCPR is the in-hospital resuscitation event registry sponsored by the American Heart 
Association (AHA). For more information about the NRCPR and the support it provides for practice 
management and quality improvement, go to http://www.nrcpr.org/. 

The CodeNet Administrator’s Guide provides information on the optional tools available in CodeNet: 
• Completing highlighted fields in CodeNet Central and CodeNet Writer 
• Customizing tab views 
• Documenting HIPAA disclosure information 
• Performing code audits 
• Submitting cases to NRCPR 

Get the Latest Revision of this Book 
The latest revision of the PDF version of this book is automatically transferred to your system 
whenever you perform an upgrade. 

You can also download the latest PDF version of this book at any time: 
a. Go to www.zoll.com. 
b. Click Documentation. 
c. Click CodeNet Event Data Management. 
d. Under CodeNet Resources, click Literature. 
e. Click the document you want to view. 
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Chapter 2 Overview 
There are typically two types of users for CodeNet, a documenter (submitter) and an administrator 
(code auditor). The submitter documents the code in CodeNet Writer and uploads the defibrillator 
record to the mobile device. The mobile device is then connected to the CodeNet Central workstation 
and the data is moved to the central share folder on the network. The submitter views the case on 
the workstation and enters missing data. Later, the code auditor reviews all cases and may add 
additional data, if necessary.  

CodeNet uses Windows user groups to control access to the desktop application, thereby allowing 
only CodeNet users to start the application and controlling functionality by user type. 

• CodeNet Users. Only members of this group can start CodeNet Central. All CodeNet users 
must be a member of this group. 

• CodeNet Submitters. Only members of this group are restricted from opening cases outside 
of the unsubmitted folder. Users that will be responsible for documenting codes should be a 
member of this group. 

• CodeNet Administrators. Only members of this group can access Tools › Options. Users that 
will be responsible for reviewing cases in the Submitted and Unsubmitted folders should be 
a member of this group. 

See CodeNet Hardware Software Specifications for detail on Active Directory user groups and 
CodeNet Central configuration. 
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Chapter 3 Configuring Tab Views 
In CodeNet Central, 14 tabs are displayed to the user by default. This number of tabs can be 
overwhelming, especially if you only enter data on four of those tabs. CodeNet Central provides the 
ability to specify which tabs are displayed to the user. The configuration of the tabs to display is 
stored for each user separately and can be set in CodeNet Central by choosing Tools > Options. For 
detailed instructions, see the CodeNet Central Getting Started Guide. However, since you would 
have to log into Windows as each user to set the view configuration, this may not be the easiest way 
to accomplish this task. 

There is a more efficient way to accomplish this when all your users need the same tab view. 
Contact your deployment specialist about the tabs that you would like to omit. A custom license.cfg 
file will be created to define the view you want. In this solution, the settings apply to all users of that 
workstation. If you limit the number of tabs to be displayed, this workstation should be used by 
CodeNet submitters only; CodeNet administrators should have access to all 14 tabs and will need to 
run CodeNet on a separate machine. 

Note: The tabs for which the submitters will be responsible vary by hospital. 
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Chapter 4 HIPAA 
The Health Insurance Portability and Accountability Act (HIPAA) is a federal law passed in 1996 that 
allows group coverage to be ported from one carrier to another and includes a privacy rule for 
protecting personal health information (PHI). 

HIPAA Disclosure Log 
CodeNet Central automatically records events in which a patient’s PHI is revealed. There are five 
such events recorded in the HIPAA disclosure log, as described in Table 1. 

Note: For the document event to take place, the user must manually enter a HIPAA Disclosure Note 
available in the Edit menu. The event is then automatically added to the HIPAA disclosure log. 

Table 1. HIPAA Disclosure Log Events 
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Printing the HIPAA Disclosure Log 
The HIPAA Disclosure log is available as a report from the Print menu. To access this report, choose 
File > Print > Case > HIPPA Disclosure (Figure 1). 
 
Figure 1. HIPAA Disclosure Report 



    
 

CodeNet • 7 

Chapter 5 Code Audit: Highlighted fields 
 
 

 
 

269 Mill Road 
Chelmsford, MA 01824-4105 
800-348-9011 Toll Free 
978-421-0025 Telefax 
www.ZOLL.com    
Latest docs: www.zoll.com/CodeNetDocs 

 
D

o
c

u
m

e
n

t
a

t
io

n
.

Chapter 5 Code Audit 
CodeNet Central provides mechanisms to help ensure that data entered for a case is complete. For 
example, fields highlighted in red let the user know that required information is missing. The code 
audit process tracks incomplete cases to their completion. 

Highlighted fields 
You must complete the following red highlighted fields on the Code Record tab before you can submit 
a case for code audit. If you do not complete these fields, you will be prompted to do so before the 
code audit submission will be successful. 

• Patient ID/MR Number 
• Last Name 
• Event Type 
• Patient Type 
• Physician Leader 
• Recorder 

The Code Quality tab also requires data. You can either select No code quality issues or enter the 
required information. 

Events on the Code Log tab will be displayed in red text if either data is missing or the data needs to 
be transcribed. However, there is one scenario in which an event may be marked blue to indicate a 
potential issue: the defibrillator event was manually recorded in CodeNet Writer and automatically 
recorded by the defibrillator, thereby resulting in two identical events instead of one unique event. 
CodeNet Central marks the event blue to indicate a possible duplicate shock. You can still submit a 
blue event for code audit. In the case where defibrillator data exists, CodeNet Central interprets 
manually-recorded shocks as duplicate shocks and hides them from the user. However, if no 
defibrillator data exists, the software displays the manually-recorded shocks in black text, indicating 
that they are unique events. You can display the hidden shocks, using the Show All Hidden Shocks 
button. When you click this button, CodeNet Central displays the possible duplicate shocks in blue 
text, and displays Duplicate? in the Comments column. You can accept or re-hide the duplicate 
shocks. If you accept them, using the Accept Duplicate Shock button, CodeNet Central changes the 
text that represents the shock from blue to black, thereby marking the shock as a unique event. If 
you hide them, using the Hide All Duplicate Shocks button, they will again be hidden from view and 
be ignored. 

Note: Defibrillator recorded shock events will always be considered unique events, be visible, and 
appear in black text. 
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Code Audit Process 
The code audit process involves four statuses: Unsubmitted, Submitted, Rejected, and Accepted, 
each of which can be searched on individually. The process may include: 

• Reviewing the work of a code documenter. 
• Viewing, adding, or editing the information submitted by the code documenter. 
• Viewing, adding, or editing information on tabs on which the code documenter does not 

work. 
• Accepting the case, or rejecting it and returning it to the code documenter for additional 

work. 

Note: The code audit features work in conjunction with the Windows user groups. See Chapter 2. 
With the Windows groups in place, the submitter can submit the case only. The Administrator can 
submit, reject, or accept cases. 

To submit, accept, or reject a case: 
1. Choose Tools > Code Audit, and then choose Submit, Accept, or Reject from the CodeNet 

Central main window. A popup window opens, prompting you to enter comments about the 
case. 

2. Enter comments, such as an explanation as to why a case is being submitted with missing 
information or why a case is being rejected.  

3. If you want to send an e-mail, go to Step 4. If you do not want to send an email, click OK to 
complete the action (submit, accept, or reject the code record). 

4. If you want to send an e-mail to indicate that a change has occurred in the code audit status, 
click the Notify via email checkbox and then click OK to complete the action (submit, accept, 
or reject the code record). A new message of the installed MAPI-compliant e-mail application 
opens, as shown in Figure 2. 

Figure 2. Code Record E-mail Window 
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5. In the body of the e-mail, CodeNet Central includes your comments and the name of the 
patient. The Subject: field contains the submitter’s name and time of the audit status 
transition. The To: field is blank. 

If you want the To: field to always contain the e-mail address of the code auditor, choose 
Tools > Options > Code Audit. In the Default email address for audit notifications: field, enter 
the e-mail address of the person to which you want to send the messages. When you 
configure an e-mail address, the Notify via email checkbox in the popup window will always 
be selected. If you do not configure an e-mail address, the Notify via email check box is not 
selected, thereby making it optional. 

. 
6. Click Send to send the e-mail. 

Code Audit History 

You can display the history of the code audit from the Code Audit History tab (Figure 3) on the 
CodeNet Central main window. The history information includes the date and time of the action, the 
action performed (Rejected, Submitted, or Accepted), the name of the user who performed the 
action, and any comments that the user entered in the popup window. 

Figure 3. Code Audit tab 
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Chapter 6 NRCPR 
CodeNet Central allows you to submit resuscitation data to the National Registry of Cardiopulmonary 
Resuscitation (NRCPR). Hospitals that participate in NRCPR receive an NRCPR software CD. The 
NRCPR will train one or more users from those hospitals on how to use the NRCPR software and 
participate in the NRCPR program. NRCPR provides a local database file in which the records are 
stored until the hospitals submit them to the NRCPR. Some hospitals choose to submit their NRCPR 
records once every three months; others may choose to submit their records more frequently, such 
as once a month. 

For more information on NRCPR, go to http://www.nrcpr.org. To purchase the NRCPR application, 
contact your ZOLL Sales Representative. 

CodeNet Integration 
NRCPR has its own application that is installed on the workstation. NRCPR is responsible for 
assigning a facility ID, authorized users, and pointing the software to the correct local database file. 
Your CodeNet deployment specialist will assist you in creating an ini file that points to your CodeNet 
installation directory.  This file will be placed in the NRCPR install folder so that the NRCPR software 
knows where CodeNet is installed and the interaction between the two applications can take place. 
Once this is completed, data stored in CodeNet can be imported into the local NRCPR database.  
There is no additional configuration needed in CodeNet Central. 

Since not every case will meet the criteria for NRCPR, hospitals must review each case individually 
in CodeNet Central and decide whether to submit it to the NRCPR. 

Importing Cases into NRCPR 
A case is ready for review in CodeNet Central.  As the CodeNet Administrator and person trained in 
NRCPR, you decide whether the case meets the NRCPR criteria.  If yes, you will need a few bits of 
data from the event so that you can create the event in the NRCPR application.  NRCPR will use this 
data to match against the event in CodeNet so that the correct event is imported.   

Starting in CodeNet Central, you will want to take note of the event start time. For a cardiopulmonary 
event, this is the time Need for compressions or defibrillation first recognized. For a respiratory 
event, this is the time Need for assisted ventilation first recognized. Also for a respiratory event, you 
will need to know the time of ROV/ROSV or cardiac event began as well as the Reason resuscitation 
ended (reason respiratory event ended). 

Note: The Code Record report contains all this needed data. 

With this information in hand, make sure the case is closed in CodeNet Central and then follow these 
steps: 

1. Launch NRCPR. 

2. Search on the patient last name. 

3. Choose whether to Add Admission & First Event or Add Another Event as appropriate. 

http://www.nrcpr.org/
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4. Complete the requested data fields to the point that the event is created and the data tabs 
for the event are presented.  

Note: CodeNet Central’s time format is HH:MM:SS and NRCPR’s format is HH:MM.  The 
seconds are ignored. 

5. The Import menu will now appear in the main NRCPR application window. Click Import > 
Import from ZOLL. 

6. A successful import will display the message “Data loaded”. An unsuccessful import will 
display the message “No record found”. See the Troubleshooting section that follows. 

7. You are now ready to complete the information for the event and validate the record for 
NRCPR. Refer to documentation provided by NRCPR for completing records and 
transmitting them to the NRCPR. 

Troubleshooting 
Error: “No record found” 
There are several different causes of this error. After trying a solution, go back to NRCPR and 
attempt to import again.  If you receive the same error, go on to the next solution. 
 
Cause: Record is open in CodeNet Central; file is locked. 
Solution: Close the record in CodeNet Central. 

Cause: Dates/times do not match. 
Solution: For a cardiopulmonary event, verify Need for compressions or defibrillation first 
recognized date and time match the event date and time entered in NRCPR. For a respiratory event, 
verify Need for assisted ventilation first recognized date and time match the event date and time in 
NRCPR. Also verify the reason the respiratory event ended and the time are identical in CodeNet 
Central and NRCPR. If any time is marked Unknown, verify this is marked as such in both CodeNet 
Central and NRCPR. 

Cause: MR number does not match. 
Solution: Verify MR number is identical in CodeNet Central and in NRCPR. 

Cause: Patient last name does not match. 
Solution: Verify patient last name is identical in CodeNet Central and in NRCPR. 
 



    
 

CodeNet • 12 

Chapter 7 Getting Help: Technical and Sales support 
 
 

 
 

269 Mill Road 
Chelmsford, MA 01824-4105 
800-348-9011 Toll Free 
978-421-0025 Telefax 
www.ZOLL.com    
Latest docs: www.zoll.com/CodeNetDocs 

 
D

o
c

u
m

e
n

t
a

t
io

n
.

Chapter 7 Getting Help 
Technical and Sales support 
For customers in the United States, contact ZOLL Medical Corporation at the following 
address, telephone numbers, e-mail address, fax number, or URL if you have questions about using 
the RescuNet software or want information about software sales, upgrades, 
and support contracts: 
 
ZOLL Medical Corporation 
269 Mill Road 
Chelmsford, MA 01824-4105 USA 
Telephone: toll free (800) 348-9011 or (978) 421-9655 
E-mail: TechSupport@zoll.com
Fax: (978) 421-0015 
Web: www.zoll.com
 
For customers in all other locations, either send e-mail to TechSupport@zoll.com or contact 
your nearest authorized local ZOLL representative. International offices: 
http://www.zoll.com/contact.htm.

 

http://www.zoll.com/
www.zoll.com/contact.htm.
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